BTerrell Group Blog

Sage Accpac ERP Version 5.4 Retirement

Posted by Meredith Gooch on Thu, Feb 03, 2011

Support for Sage Accpac ERP Version 5.4 will be discontinued as of April 1, 2011. If you are still using version 5.4 please contact us to schedule your upgrade. Sage's policy states that they will provide support for the current version and two versions back, with product updates being made available for the current version only. With the release of version 6.0 in December 2010, Sage will no longer support version 5.4. Versions 5.5 and 5.6 will remain supported until the release of the next version, 6.1.

upgrade

Tags: Accpac 5.4 discontinued, accpac 5.4, accpac version supported